
Using convetional graphics, you can define only one hot spot per graphic. 
Although that is useful, it limits the way in which you can link other kinds of 
information to pictures. Fortunately, Windows Help provides a tool that lets you 
define many hot spots using a single picture. This chapter describes how to add 
multiple hot spots to graphics so that they can link to other information in the 

Help file.

A hypergraphic is a picture containing one or more hot spots. Like bitmap hot 
spots, hypergraphics let you use graphics instead of text to create links to other 
topics, display information in pop-up windows, and execute Help macros. The 
difference between bitmap hot spots and hypergraphics is that, using 
hypergraphics, you can define multiple hot spots within the same picture to 
perform all these operations. In this way, creating hypergraphics extends the 
usefulness of graphics in your Help file.

Conceptually, a hypergraphic consists of two layers:

n A Windows bitmap or metafile
n One or more rectangular hot spots superimposed on the bitmap

The bitmap or metafile creates the picture that the user sees in the Help window, 
and the hot spots define regions within the picture that the user can interact with.

Here are just a few examples of how you might use hypergraphics in a Help file:

n Take a screen shot of a dialog box in your application and define hot 
spots for each field so that a user can click the hot spots and learn 
how to use the dialog box options.

n Create an illustration and add hot spots over different parts of the 
illustration that the user can click to see a description of the 
corresponding part.

Creating Hypergraphics

_____________________________________________________ Chapter 11

What Are Hypergraphics?
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n Create a Contents screen or Help menu using a picture so that you 
can control the placement of text and graphics more precisely than 
with paragraph formatting. Define hot spots over the appropriate 
icons or jumps to give users access to the Help topics.

n Create a visual map and add hot spots that jump to topics on the 
different regions shown in the map.

n Create buttons for each letter of the alphabet and arrange them in 
groups (as a typewriter keyboard does, for example). Use the button 
picture as a hypergraphic in an online index or glossary so that the 
user can click a letter and see the entries for that letter of the 
alphabet.

n Create a series of pictures that depict different states of an action or 
simulation. Make each picture in the series a hypergraphic so that 
when the user clicks a hot spot the picture changes to show the new 
state (like a door opening and closing, for example).

The rest of this chapter explains how to create and add hypergraphics to your 

Help file.

To create hypergraphics you use Hotspot Editor, an application that lets you open
any standard Windows bitmap or metafile and add hot spots to it. You can then 
save the bitmap in hypergraphic format, with the picture and hot spots combined. 
Using Hotspot Editor, you can define hot spots that link to other Help topics and 
graphics, that execute a Help macro, or that access multimedia events (if 
provided for by external DLLs). After you create a hypergraphic and save it with 
Hotspot Editor, you can add it to Help topics exactly like any other bitmap. The 
only restriction is that hypergraphic files produced by Hotspot Editor must be 
included by reference using the bmc, bmr, or bml format. (For an explanation of
these formats, see Chapter 10, “Adding Graphics.”)

Although you can create similar effects in the Help file by carefully creating and 
positioning several individual bitmaps next to each other and formatting each of 
them as hot spots, Hotspot Editor is more efficient and much easier to use. Using 

Hotspot Editor
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several bitmaps to simulate a single-image hypergraphic also has the drawback of
requiring Help to perform multiple locating operations when displaying the topic. 
Usually this means Help must read the disk several times, slowing overall 
performance, especially on CD-ROM.

If you are creating a 3.0 Help file, you cannot use Hotspot Editor. In that case, 
see “Creating Hypergraphics Without Hotspot Editor,” later in this chapter.

Starting Hotspot Editor

Hotspot Editor is an independent application that runs in the Windows operating 
system, so you can start it the same way you start other applications in Windows. 
If you selected the option to install the graphics tools when you installed Help 
Author, the setup program automatically creates a program item icon for Hotspot 
Editor in the Help Author group window of Program Manager.

To start Hotspot Editor

n Open the Help Author group in Program Manager and double-click 
the Hotspot Editor icon.

If you did not use the setup program to install Hotspot Editor, you can add a 
program item icon for it in a Program Manager group.

To create a program item for Hotspot Editor

1. Open the group in the Program Manager window where you want to 
add the program item.
2. From the File menu, choose New.
3. Select the Program Item option, and then choose OK.
The Program Item Properties dialog box appears. 
Tip     To open this dialog box quickly, hold down the ALT key and 
double-click in an empty part of the group window. 
4. Type Hotspot Editor in the Description box.
5. In the Command Line box, type SHED.EXE and include a path if 
the application is not in your Windows directory.
For example, you might type c:\hlptools\shed.exe
You can also use the Browse button and select the application filename 
from the directory where it is stored .
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6. Fill in the remaining options in the Program Item Properties dialog 
box if you want to, and then choose the OK button. 
For help with the Program Item Properties dialog box, choose the Help 
button or press F1 while using the dialog box. 

Importing Image Files

To create a hypergraphic, you must first import the graphic that you want to use 
to define hot spots. Because Hotspot Editor is not a draw or paint program (it’s an
editor only), you must create the actual graphic image outside Hotspot Editor. 
Hotspot Editor creates a hypergraphic (.SHG) file when the imported graphic 
image is saved.

Hotspot Editor can open and save any standard Windows bitmap (.BMP) or 
device-independent bitmap (.DIB) created by a Windows draw or paint program, 
such as Windows Paintbrush. If you are using Windows Paintbrush, you should 
save the image file as a monochrome bitmap or 16-color bitmap. Hotspot Editor 
is also compatible with standard Windows metafile (.WMF) files.

Note

If Hotspot Editor cannot open the file because it is in an 
unsupported format, you can take a screen shot of it, paste it into 
Windows Paintbrush, and then save it as a Windows bitmap. If you 
can’t display the picture in Windows, you must use a conversion utility 
to convert the file to a supported format.

Note

If you change an image file after you have edited the graphic in 
Hotspot Editor, you can re-import the modified image file in Hotspot 
Editor without losing any hot spot information. For more information, 
see “Editing and Replacing Images,” later in this chapter.



Creating Hypergraphics§   11-5

Hotspot Editor Window

Hotspot Editor has a standard multiple document interface (MDI) window that 
lets you edit multiple graphic images at the same time. Each image that you open 
in Hotspot Editor is displayed in a separate document window. Switching from 
one document window to another does not affect previously selected windows. 
Likewise, actions performed on a document window affect only that window. 
Document windows can be minimized; Hotspot Editor displays, as accurately as 
possible, a reduced version of the image in the minimized window icon. The 
status bar at the bottom of the Hotspot Editor window displays a brief description 
of the currently selected menu or command and attribute information for the 
currently selected hot spot.

Hotspot Editor Menus

Hotspot Editor has four menus: File, Edit, Window, and Help. The commands for
these menus are described in the following lists.

The File Menu
Commands on the File menu let you open or save graphics files.

Command Description

Open Opens existing 16-color bitmaps (.DIB or .BMP), 
metafiles (.WMF), or hypergraphics (.SHG). More 
than one graphic file can be open at one time.

Close Closes the currently selected document window.

Save Saves changes to a hypergraphic. Hotspot Editor 
displays a warning if you are overwriting the 
original bitmap.

Save As Saves a hypergraphic under a different name. The 
default extension .SHG is used if one is not 
specified.



   Microsoft Windows Help Authoring GuideExit Exits Hotspot Editor.

File Names Opens a previously edited image file or 
hypergraphic. Hotspot Editor lists the last four 
graphics you edited on the File menu.

The Edit Menu
Commands on the Edit menu let you edit hot spots and define their attributes.

Command Description

Undo Undoes the last action you performed.

Attributes Displays the attributes for each hot spot. Attributes include the 
binding string, binding type, binding attribute, hot-spot identifier, 
and the bounding box coordinates. (For more information about 
hot-spot attributes, see “Adding Hot Spots to Bitmaps,” later in 
this chapter.)

Select Displays a dialog box listing all the defined hot-spot IDs for the 
bitmap. You choose an item from the list to select a particular hot 
spot.

Delete Removes the currently selected hot spot.

Cut Removes the currently selected hot spot from the hypergraphic 
and places it in the Clipboard.
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Clipboard.

Paste Pastes a graphic or hot spot from the Clipboard. If the Clipboard 
contains a graphic, it is pasted into Hotspot Editor. If the 
Clipboard contains a hot spot, it is pasted in the upper-left corner 
of the graphic. You can then move the hot spot to the desired 
location.

Replace Replaces the underlying bitmap in a hypergraphic without losing 
any hot spot information that has already been defined for the 
hypergraphic.

Preferences Displays a dialog box that lets you set default values for the 
binding string, binding type, binding attribute, and hot-spot 
identifier options of the Attributes command.

The Window Menu
Commands on the Window menu let you arrange and select Hotspot Editor 
windows and icons.

Command Description

Cascade Arranges and resizes the open graphic windows so 
that each title bar shows.

Tile Arranges and resizes the open graphic windows so 
that they all fit in the workspace without 
overlapping.

Arrange Icons Aligns the graphic window icons evenly along the 
bottom of the main Hotspot Editor window.
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windows. To select a window and display its 
graphic, choose the window name from the list.

The Help Menu
Commands on the Help menu display Help and copyright information for Hotspot
Editor.

Command Description

Contents Displays the Contents topic for the Hotspot Editor Help file.

About Displays information about the Hotspot Editor application, 
including copyright notice and version number.

If you are opening menus, the gray status bar at the bottom of the Hotspot Editor 
window displays information about the currently selected command. It also 
displays information about commands and hot spots.

Once you select a hot spot, the status bar displays the following information for 
that hot spot:

n Context string
n Binding type
n Binding attribute
n Hot-spot identifier
n Bounding box coordinates
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Opening Image Files

Before you can add hot spots to a bitmap with Hotspot Editor, you must first 
create an image file and then open it in Hotspot Editor to edit. To edit more than 
one image file at a time, open multiple files. Each file appears in its own 
document window in Hotspot Editor.

Opening New Files

To open a new image file

1. From the File menu, choose Open.
The Open dialog box appears.
2. If the file is in the current directory, select the name of the file in the 
Files box.
If the file is not in the current directory, double-click the directory you 
want in the Directories box, and then select the name of the file in the 
Files box.
Hotspot Editor displays in the Files box only those files whose 
extensions match the supported file formats.
The current directory is shown below the File Name box. Double-
clicking the two periods [..] at the top of the Directories box shows the 
files and directories located one level closer to the root directory.
3. Choose OK.
Instead of using the Files and Directories boxes to open a file, you can 
type the complete path in the File Name box, and then click OK.

Opening Previously Edited Files
Hotspot Editor records the last four files you opened. Their paths and filenames 
are displayed at the bottom of the File menu in Hotspot Editor.

You can open a previously edited file in two ways: either choose the file you 
want to open from the File menu or type the number that appears to the left of the
file you want to open.

Adding Hot Spots to Images

After opening an image file in Hotspot Editor, you can create hot spots that link 
to text, graphics, or multimedia events. You insert hot spots to the areas of the 
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picture that you want to be hot, just as you determine what text you want to be hot
in the topic files. For example, you might want to make a button in a screen shot a
hot spot that creates a pop-up window when the user chooses the hot spot.

For each hot-spot you add to an image, you follow the same two steps.

To add a hot spot

1. Draw the hot spot rectangle on top of the image.
This defines the region that the user will click to activate the hot spot.
2. Define the properties for the hot spot.
This determines what action Help will take when the user choose the 
hot spot.

Drawing Hot Spots
A hot spot can be any rectangular area of the graphic image. Defining a hot spot 
is similar to drawing a rectangle in a draw or paint program.

To draw a hot spot on an image

1. Position the mouse pointer on the bitmap where you want to define a 
hot spot and press the left mouse button.
This creates the anchor for one corner of the hot-spot rectangle.
2. While holding down the left mouse button, drag the mouse until the 
rectangle encloses the area you want to define as the hot spot.
A flexible box stretches from the anchor point to the position of the 
mouse pointer, expanding and contracting as you move the mouse.
3. When you are satisfied with the size of the hot-spot rectangle, release
the mouse button.
After you release the mouse button, the hot-spot rectangle displays 
eight sizing handles, indicating that it is the currently selected hot spot. 
You can use the sizing handles to resize the rectangle.
Your hot spot should look like the one in Figure 11.1.

Graphic
You can draw hot spots so that they overlap each other; however, in the built 
Help file, only the top most hot spot is active in a stack of overlapped hot spots.
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Creating a Tabbing Order

In the built Help file, users can select the hot spots either with the mouse or with 
the keyboard. When using a keyboard, users press the TAB key to move from 
one hot spot to the next. This is called the tabbing order. 

Hotspot Editor creates the tabbing order in the same order that you create the hot 
spots within the graphic.

To create a specific tabbing order

n Define each hot spot in the same order you want users to follow in 
the built Help file.

Viewing the Tabbing Order
After you have created one or more hot spots, you can view the tabbing order by 
using the Select command on the Edit menu.

To view the tabbing order in a hypergraphic

n From the Edit menu, choose Select.
The Select dialog box appears, listing all the defined hot-spots in the 
hypergraphic. The hot spots are displayed in the order in which they 
were created, with the first hot spot at the top of the list box.

Changing the Tabbing Order
If you have already created hot spots in a hypergraphic, and later you want to 
change the tabbing order, you can use commands on the Edit menu to do so.

To change the tabbing order

1. From the Edit menu, choose Select.
The Select dialog box appears with the hot spots listed in the current 
tabbing order, as shown in Figure 11.x.

Graphic
2. Select the hot spot that you want to move to the top of the tabbing 
order.
3. Choose the Select button.
The hot-spot rectangle displays eight sizing handles, indicating that it is
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the currently selected hot spot.
4. From the Edit menu, choose Delete.
Or press the DEL key.
The hot spot is deleted.
5. From the Edit menu, choose Undo.
The hot spot is restored to the hypergraphic, and it is moved to the top 
of the tabbing order. To view the new tabbing order, use the Select 
command.
6. From the Edit menu, choose Select to view the new tabbing order.
The selected hot spot is at the top of the tabbing order, as shown in 
Figure 11.1.

Graphic
Note     If you did not assign unique identifiers to each hot spot, it may 
be impossible to tell that the tabbing order has changed.
7. Repeat steps 1—5 to move another hot spot.

Defining Hot-Spot Attributes

After creating a hot spot, you must define its attributes in the Attributes dialog 
box. Hot-spot attributes include binding information for the hot spot, the hot-spot 
name, and the bounding box coordinates. 

The following table describes the hypergraphic attributes.

Field Description

Context String Specifies binding information for the hot spot, in the 
form of a context string or a macro.

Type Indicates the type of action to be taken when the 
user chooses the hot spot. The four binding types are
pop-up, jump, macro, and searchable.

Attribute Specifies whether the hot spot is to be visible or 
invisible when displayed to the user in the Help 
window. Hot spots are always visible in Hotspot 
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Editor.

Hotspot ID Specifies a unique identifier for the hot spot. The 
hot-spot name is used internally by Hotspot Editor to
make it easier to identify hot spots in the Select 
dialog box. Hotspot Editor assigns an incremental 
number to the hot-spot name; however, you can type
your own unique name.

Bounding Box Coordinates Displays the coordinates for the hot-spot rectangle: 
left, right, top, and bottom. The coordinates are 
measured in pixels and are restricted to the size of 
the graphic image.

To define attributes for a hot spot

1. Select the hot spot and choose Attributes from the Edit menu.
Or click the hot spot with the right mouse button.
Or double-click the hot spot with the left mouse button.
Or select the hot spot and press ENTER.
The Attributes dialog box appears (Figure 11.2).

Graphic
Note
If you use the right mouse button to define a hot-spot rectangle, 
Hotspot Editor displays the Attributes dialog box when you release 
the mouse button.

2. Complete the Attributes dialog box and choose OK.
The attributes defined for the hot spot appear in the Hotspot Editor 
status bar.
For more information about each attribute, see the preceding attributes 
table.
3. Repeat this process for each hot-spot region that you want to define.

To define a jump hot spot

1. From the Type list, choose Jump.
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2. In the Context String box, type the context string of the topic Help 
jumps to when the user chooses the hot spot.
3. Choose OK.

To define a pop-up hot spot

1. From the Type list, choose Pop-up.
2. In the Context String box, type the context string of the topic that 
Help displays in the pop-up window when the user chooses the hot spot.
3. Choose OK.

To define a macro hot spot

1. From the Type list, choose Macro.
2. In the Context String box, type the macro (or macros) that Help 
executes when the user chooses the hot spot.
For a Help macro, type the macro. (For more information, see Chapter 
15, “Help Macros.”)
3. Choose OK.

To define a searchable hot spot

1. From the Type list, choose Searchable.
2. In the Context String box, type the keyword (or keywords) that you 
want to associate with this hypergraphic.
Separate each keyword with a semicolon. (For more information, see 
Chapter 6, “Creating Topics.”)
3. Choose OK.

To define the appearance of the hot spot

1. Choose Visible or Invisible for the binding attribute.
Visible hot spots are outlined in black or are displayed in inverse video.
2. Choose OK.

To change the default name assigned to the hot spot

1. In the Hotspot ID box, type the name you want to assign to the hot 
spot.
This name helps you identify the hot spots in the graphic if you use the 
Select command (described in the next section). If you don’t enter a 
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hot-spot name, Hotspot Editor appends a number at the end of the name
Hotspot.
2. Choose OK.

To change the size or location of the hot spot

1. Edit the bounding box values.
The numbers used in the bounding boxes represent pixels.
2. Choose OK.

Setting Preferences
When you define a hot spot, Hotspot Editor uses the binding information and hot-
spot identifier stored in the Preferences dialog box. To change the default values, 
edit them. Setting your own preferences for hot-spot attributes saves time and 
effort when creating hypergraphics that require settings different from Hotspot 
Editor’s internal defaults. Hotspot Editor assigns the attributes you enter to 
subsequent hot spots created with these preferences.

The following table shows the default setting for each attribute.

Field Default entry

Context String (Empty)

Type Jump

Attribute Invisible

Hotspot ID Hotspot
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To change Hotspot Editor preferences

1. From the Edit menu, choose Preferences.
2. In the Context String box, type a context string or macro.
3. Select the binding type.
4. Select the binding attribute.
5. Type a hot-spot name.
This entry affects only the hot-spot name. Hotspot Editor continues to 
assign numbers incrementally to each new hot spot.
6. Choose OK.

Editing Hot Spots

After you create a hot spot, you can select it for editing and then cut, copy, paste, 
delete, resize, or move it. When editing hot spots, all attributes defined for the hot
spot remain with the hot spot.

Selecting Hot Spots
A selected hot spot contains eight sizing handles that you can use to resize the 
hot-spot rectangle.

To select a hot spot

n Click the hot spot with the left mouse button.
Or press TAB or SHIFT+TAB until you select the hot spot you want.

To select a hot spot using the Select command

1. From the Edit menu, choose Select.
The Select dialog box appears. All hot spots defined for the 
hypergraphic appear in the Hotspots box. By default, Hotspot Editor 
does not select a hot spot in the list unless one was selected before 
choosing the Select command. In that case, Hotspot Editor highlights 
the currently selected hot spot.
2. In the Hotspots box, select a hot-spot name.
Hotspot Editor displays the binding information for the selected hot-
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spot name.
3. Choose the Select button.
The hot spot shows eight sizing handles to indicate that the hot spot is 
selected.

Deleting Hot Spots

To delete a hot spot

1. Select the hot spot.
2. From the Edit menu, choose Delete.
Or press the DEL key.

Cutting or Copying Hot Spots
Hotspot Editor lets you transfer hot spots to and from the Clipboard using the Cut,
Copy, and Paste commands on the Edit menu. Transferring hot spots is useful to:

n Create multiple versions of the same hot spot with the same 
attributes.

n Move a hot spot from one image file to another.
n Save time when repeatedly defining hot spots in a hypergraphic.

To cut or copy a hot spot to the Clipboard

1. Select the hot spot.
2. From the Edit menu, choose Cut or Copy.
Hotspot Editor transfers the selected hot spot to the Clipboard using 
Hotspot Editor’s proprietary clipboard format.

Pasting Hot Spots
You can paste images or hot spots from the Clipboard into Hotspot Editor. 
Pasting an image is the same as opening the file. If you paste a hot spot, Hotspot 
Editor pastes it in the upper-left corner. You can paste a hot spot into the same 
image file or another image file.

To paste a hot spot
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n From the Edit menu, choose Paste.
The hot spot is pasted in the upper-left corner of the hypergraphic being
edited.

Moving Hot Spots
After you create a hot spot, you can move it anywhere within the current image 
area.

To move a hot spot

1. Select the hot spot.
2. Position the mouse pointer in the center of the selected hot spot.
The pointer changes to a hand, indicating that you can move the hot 
spot.
3. Drag the hot spot to the new location and release the mouse button 
when the hot spot is where you want it.
The hot-spot sizing handles disappear while dragging and reappear 
when you release the mouse button.

Note

If the Hotspot Editor window is larger than the graphic 
displayed in the image area, Hotspot Editor does not let you move the 
hot spot outside the image area. If the window is smaller than the image
area (that is, if the window shows scroll bars), Hotspot Editor scrolls in 
the direction of the attempted move if a hot spot crosses the edge of the 
scroll bar.

Resizing Hot Spots
The eight sizing handles on a hot spot let you change its size the same way you 
change the size of a window.

To resize a hot spot

1. Select the hot spot.
2. Position the mouse pointer on the sizing handle on the border or 
corner that you want to change.
The pointer changes to a two-headed arrow.



Creating Hypergraphics§   11-19

3. Drag the sizing handle until the rectangle is the size you want.
If you drag a side handle, the rectangle changes size on only one side, 
the side of the border you drag. If you drag a corner, the two adjoining 
sides that form the corner change size at the same time.
4. Release the mouse button.

Saving the Hypergraphic

After you have defined all the hot spots and made all your changes to the image, 
you save it as a hypergraphic.

To save a hypergraphic

n From the File menu, choose Save As to save the file with hot spots 
using the .SHG filename extension provided by Hotspot Editor.

Hotspot Editor saves your graphic with the appropriate hot-spot coding.
You can now include this graphic in your Help file using a bmc, bml, 
or bmr reference.

Editing and Replacing Images

Sometimes you will create a hypergraphic and then discover that you need to 
change the original picture used in the hypergraphic. Since you cannot use 
Hotspot Editor to change the graphic, you must use the graphics application that 
created the original image. 

However, after an image has been saved as a hypergraphic (.SHG file), it cannot 
be opened again in the original graphics program. Because Hotspot Editor does 
not alter the original bitmap or metafile when creating the hypergraphic, you can 
edit the original bitmap (.BMP) or metafile (.WMF) in the graphics program and 
then re-import it into Hotspot Editor after you have made your changes.

To edit or replace the bitmap in a hypergraphic

1. Open the original bitmap or metafile in the graphics application you 
used to create the image.
Or create a new bitmap for the hypergraphic.
2. Make your changes to the image.
3. Save the edited image in the graphics application.
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4. Copy the image to the Clipboard.
5. Start Hotspot Editor and open the hypergraphic that contains the 
graphic you want to replace.
6. From the Edit menu, choose Replace. 
The new or edited graphic replaces the original bitmap.
Note     If the new image is smaller than the original graphic included 
in the hypergraphic, Hotspot Editor may move the hot spots to ensure 
that they are still on top of the image.
7. Save the changes to the hypergraphic. 

Preparing Hypergraphics for Different Displays

Normally, when it saves a bitmap in .SHG format, Hotspot Editor records the 
display resolution (EGA, VGA, or 8514) in the .SHG file based on the resoultion 
of the computer it’s running on and ignores the resolution information stored in 
the original bitmap. This can cause problems if you want to display your 
hypergraphics on different display resolutions. For example, if you have three 
bitmaps, created on EGA, VGA, and 8514 devices, and you edit them with 
Hotspot Editor on a VGA system, Hotspot Editor marks all the resulting .SHG 
files as VGA. 

To correct this problem, you can either can save the hypergraphic with the 
correct resolution information, or you can compile these files with Help’s Multi-
Resolution Bitmap Compiler (MRBC). For information about MRBC, see 
Chapter 12, “Creating Graphics for Different Displays.”

Saving Resolution Information
When creating hypergraphics, you can save the resolution information of the 
target monitor (not just the monitor on which they are created). This is especially 
important if you want to create hypergraphics for the Macintosh, because you 
cannot use Hotspot Editor on a Macintosh computer. Also, if you use this feature,
you do not have to compile hypergraphics with MRBC to make them appear 
correctly on different displays, including Macintosh displays. 

To save resolution information in the hypergraphic, you must add a line to your 
SHED.INI file. The entry tells Hotspot Editor whether you want to save .SHG 
files with the resolution information of a monitor other than the one on which 
they were authored. The monitor type actually saved depends upon the first letter 
of the extension, just as when using MRBC. 
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To save resolution information, add the following line to your SHED.INI file:
[Hotspot Editor]
ResBasedOnExt=1

If the value of ResBasedOnExt equals 1, Hotspot Editor sets the appropriate 
resolution based on the first letter of the file extension. The following table shows
how Hotspot Editor interprets the extensions.

First character Example Resolution

C bitmap.cbm CGA

E bitmap.ebm EGA

V bitmap.vbm VGA (default)

8 bitmap.8bm 8514

M bitmap.mbm Macintosh

other bitmap.bmp VGA

For example, if you create a hypergraphic to be displayed on a Macintosh, you 
can specify the MAC extension M and the hypergraphic will look good on a 
Macintosh display, without using MRBC.
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If you are using Windows Help 
version 3.0, or if you don’t have 
Hotspot Editor, you can create 
hypergraphics in the Help file by 
carefully positioning several 
individual bitmaps next to each 

other and formatting each of them as hot spots.

This technique might be called the jigsaw puzzle method because it is similar to 
taking a whole picture and cutting it into pieces and then pasting it back together, 
and formatting the pieces that you want to be hot as bitmap hot spots. For 
example, you could take a screen shot of a menu that has been dropped down and
make a separate bitmap of each command, as in Figure 11.3.

Graphic
In the topic file, you place the bitmap references in separate paragraphs and 
format them so that there is no space between the paragraphs. Otherwise, the 
individual bitmaps will display with white space or gaps between them. Also, you
should format all the bitmap paragraphs as Keep Together so that the individual 
bitmaps don’t wrap when the user resizes the Help window. When you have the 
bitmaps positioned, format each bitmap reference as a hot spot, as in Figure 11.4.

Graphic
The resulting graphics will look like a single hypergraphic when built into the 
Help file, as in Fugure 11.5.

Graphic
If done carefully, users will not be able to tell the difference between this 
imitation hypergraphic and a true hypergraphic created with Hotspot Editor. 
However, using several bitmaps to simulate a single-image hypergraphic has the 
disadvantage of requiring Help to perform multiple locating operations when 
displaying the topic. Usually this means Help must read the disk several times, 
slowing overall performance, especially on CD-ROM. The decreased 
performance may or may not be significant, depending on the size and number of 
bitmaps being used.

Ó 1993 Microsoft Corporation, All rights reserved
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